Cult Labs

Go Back   Cult Labs > Cult Labels > Other Labels

Like Tree1453Likes

Reply
 
LinkBack Thread Tools Display Modes
  #931  
Old 27th July 2020, 02:27 PM
J Harker's Avatar
Cult Addict
 
Join Date: Feb 2012
Location: Deepest Darkest South Wales
Default

Quote:
Originally Posted by Nordicdusk View Post
You using 4K TV or HDTV?
HDTV why Nord? Would it make a difference?

Last edited by J Harker; 27th July 2020 at 03:29 PM.
Reply With Quote
  #932  
Old 27th July 2020, 02:29 PM
J Harker's Avatar
Cult Addict
 
Join Date: Feb 2012
Location: Deepest Darkest South Wales
Default

Quote:
Originally Posted by Nosferatu@Cult Labs View Post
It might need a firmware update in order to play recently released discs, no matter how old the film!
I wonder if firmware updates are still being provided for it even. Do they continue providing them for older players?

Sent from my SM-G960F using Tapatalk
Reply With Quote
  #933  
Old 27th July 2020, 04:36 PM
Justin101's Avatar
Cult Veteran
Cult Labs Radio Contributor
 
Join Date: Sep 2009
Location: Liverpool
Default

What model have you got? Won't hurt to check out their website they generally have the firmware downloads available to install on a USB stick. My player has WiFi so it's as easy as going to settings and checking for updates.
__________________


You just gotta keep livin' man, L-I-V-I-N.

Reply With Quote
  #934  
Old 27th July 2020, 04:40 PM
Rob4's Avatar
Cultist on the Rampage
 
Join Date: Mar 2016
Default

Quote:
Originally Posted by J Harker View Post
Yes just this minute rigged my PS3 up. Discs play fine. I wonder if my (fairly old) blu-ray player needs a software update.
maybe check on a larger forum to see if the problem is specific to your player or not?
Reply With Quote
  #935  
Old 27th July 2020, 05:43 PM
J Harker's Avatar
Cult Addict
 
Join Date: Feb 2012
Location: Deepest Darkest South Wales
Default

Quote:
Originally Posted by Justin101 View Post
What model have you got? Won't hurt to check out their website they generally have the firmware downloads available to install on a USB stick. My player has WiFi so it's as easy as going to settings and checking for updates.
Just brought my player down and connected via ethernet cable. Won't even connect to the Internet anymore.

Sent from my SM-G960F using Tapatalk
Reply With Quote
  #936  
Old 27th July 2020, 06:16 PM
Nordicdusk's Avatar
Cult Veteran
Cult Labs Radio Contributor
 
Join Date: Jan 2012
Location: Ireland
Default

Quote:
Originally Posted by J Harker View Post
HDTV why Nord? Would it make a difference?
Sorry i have a 4KTV and i had the same issue i had to turn off the 4K on that hdmi port to fix it. Sorry I'm no help to you.
__________________
https://cuartoinfierno.cl/wp-content/uploads/2016/12/TSJUDER-300x169.jpg
Reply With Quote
  #937  
Old 27th July 2020, 07:26 PM
The Reaper Man@Cult Labs's Avatar
Cult Master
Cult Labs Radio Contributor
Good Trader
Senior Moderator
 
Join Date: Jan 2008
Location: Glasgow
Default



__________________

Teddy, I'm a Scotch drinker - you know that. I just have the occasional brandy when I'm not drinking.
Reply With Quote
  #938  
Old 27th July 2020, 08:17 PM
J Harker's Avatar
Cult Addict
 
Join Date: Feb 2012
Location: Deepest Darkest South Wales
Default

Quote:
Originally Posted by Nordicdusk View Post
Sorry i have a 4KTV and i had the same issue i had to turn off the 4K on that hdmi port to fix it. Sorry I'm no help to you.
Ah. No no 4k here. My eyes don't warrant the 4k upgrade.

Sent from my SM-G960F using Tapatalk
Reply With Quote
  #939  
Old 27th July 2020, 08:27 PM
J Harker's Avatar
Cult Addict
 
Join Date: Feb 2012
Location: Deepest Darkest South Wales
Default

Well finally managed a firmware update. Hasn't made a toss of difference though.

Sent from my SM-G960F using Tapatalk
Reply With Quote
  #940  
Old 27th July 2020, 08:44 PM
J Harker's Avatar
Cult Addict
 
Join Date: Feb 2012
Location: Deepest Darkest South Wales
Default

Quote:
Originally Posted by Nordicdusk View Post
Sorry i have a 4KTV and i had the same issue i had to turn off the 4K on that hdmi port to fix it. Sorry I'm no help to you.
Interesting though. I wonder if its something to do with the encode that my player just can't handle. Plays beautifully on my PS3 which ironically is even older than my samsung blu player.

Sent from my SM-G960F using Tapatalk
Reply With Quote
Reply  

Like this? Share it using the links below!

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



Our goal is to keep Cult Labs friendly. If you feel discouraged from posting by certain members' behaviour then you can e-mail us in complete confidence.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
All forum posts are contributed by members of the site; Cult Labs cannot take responsibility for all content posted on the site. If you have an issue with content posted on the site please click the 'report post' button.
Copyright © 2014 Cult Laboratories Ltd. All rights reserved.